Beginning of frontend + recipe editing
[recipes.git] / frontend / Cargo.toml
index 374be95..ed5f4d1 100644 (file)
@@ -14,18 +14,18 @@ default = ["console_error_panic_hook"]
 common = {path = "../common"}
 
 wasm-bindgen = "0.2"
-web-sys = { version = "0.3", features = ['console', 'Document', 'Element', 'HtmlElement', 'Node', 'Window'] }
+web-sys = {version = "0.3", features = ['console', 'Document', 'Element', 'HtmlElement', 'Node', 'Window', 'Location']}
 
 # The `console_error_panic_hook` crate provides better debugging of panics by
 # logging them with `console.error`. This is great for development, but requires
 # all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
 # code size when deploying.
-console_error_panic_hook = { version = "0.1", optional = true }
+console_error_panic_hook = {version = "0.1", optional = true}
 
 # `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
 # compared to the default allocator's ~10K. It is slower than the default
 # allocator, however.
-wee_alloc = { version = "0.4", optional = true }
+wee_alloc = {version = "0.4", optional = true}
 
 # [dev-dependencies]
 # wasm-bindgen-test = "0.3"