Add asynchronous call to database.
[recipes.git] / backend / Cargo.toml
index 371b0ed..cc98cf5 100644 (file)
@@ -5,7 +5,7 @@ authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
 edition = "2021"
 
 [dependencies]
-#common = {path = "../common"}
+common = {path = "../common"}
 
 actix-web = "4"
 actix-files = "0.6"
@@ -17,6 +17,7 @@ ron = "0.8" # Rust object notation, to load configuration files.
 itertools = "0.10"
 clap = {version = "4", features = ["derive"]}
 
+log = "0.4"
 env_logger = "0.9"
 
 r2d2_sqlite = "0.21" # Connection pool with rusqlite (SQLite access).
@@ -25,10 +26,14 @@ rusqlite = {version = "0.28", features = ["bundled", "chrono"]}
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
-askama = {version = "0.11", features = ["with-actix-web", "mime", "mime_guess"]}
+askama = {version = "0.11", features = ["with-actix-web", "mime", "mime_guess", "markdown"]}
 askama_actix = "0.13"
 
 argon2 = {version = "0.4", features = ["default", "std"]}
 rand_core = {version = "0.6", features = ["std"]}
 
-rand = "0.8"
\ No newline at end of file
+rand = "0.8"
+
+lettre = {version = "0.10", default-features = false, features = ["smtp-transport", "pool", "hostname", "builder", "rustls-tls"]}
+
+derive_more = "0.99"
\ No newline at end of file