Sign up form and other stuff
[recipes.git] / backend / Cargo.toml
index 7af3811..c443e9b 100644 (file)
@@ -5,23 +5,32 @@ authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
 edition = "2021"
 
 [dependencies]
+common = {path = "../common"}
+
 actix-web = "4"
 actix-files = "0.6"
-serde = { version = "1.0", features = [ "derive" ] }
+serde = {version = "1.0", features = ["derive"]}
+
+chrono = "0.4"
 
 ron = "0.8" # Rust object notation, to load configuration files.
 itertools = "0.10"
+clap = {version = "4", features = ["derive"]}
 
 env_logger = "0.9"
 
 r2d2_sqlite = "0.21" # Connection pool with rusqlite (SQLite access).
 r2d2 = "0.8"
+rusqlite = {version = "0.28", features = ["bundled", "chrono"]}
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
-common = { path = "../common" }
-
-askama = { version = "0.11", features = ["with-actix-web", "mime", "mime_guess"] }
+askama = {version = "0.11", features = ["with-actix-web", "mime", "mime_guess"]}
 askama_actix = "0.13"
 
-rusqlite = { version = "0.28", features = ["bundled"] }
+argon2 = {version = "0.4", features = ["default", "std"]}
+rand_core = {version = "0.6", features = ["std"]}
+
+rand = "0.8"
+
+lettre = "0.10"
\ No newline at end of file