Update dependencies (actix-web 2)
[recipes.git] / backend / Cargo.toml
index 3158b88..7f7e2e1 100644 (file)
@@ -5,17 +5,18 @@ authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
 edition = "2018"
 
 [dependencies]
-actix-web = "1.0"
-actix-files = "0.1"
+actix-web = "2.0"
+actix-rt = "1.0"
+actix-files = "0.2"
 askama = "0.8" # Template system
 serde = { version = "1.0", features = ["derive"] }
 listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
 ron = "0.5" # Rust object notation, to load configuration files.
 itertools = "0.8"
-env_logger = "0.6"
+env_logger = "0.7"
 
 common = { path = "../common" }
 
 [dependencies.rusqlite]
-version = "0.20"
+version = "0.21"
 features = ["bundled"]
\ No newline at end of file