Add an error management in db module
[recipes.git] / backend / Cargo.toml
index 06afa24..64f90f7 100644 (file)
@@ -10,10 +10,10 @@ actix-rt = "1"
 actix-files = "0.2"
 serde = { version = "1.0", features = ["derive"] }
 listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
-ron = "0.5" # Rust object notation, to load configuration files.
+ron = "0.6" # Rust object notation, to load configuration files.
 itertools = "0.9"
 
-r2d2_sqlite = "0.15" # Connection pool with rusqlite (SQLite access).
+r2d2_sqlite = "0.16" # Connection pool with rusqlite (SQLite access).
 r2d2 = "0.8"
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
@@ -21,11 +21,10 @@ futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 common = { path = "../common" }
 
 [dependencies.rusqlite]
-version = "0.22"
+version = "0.23"
 features = ["bundled"]
 
 # Template system.
 [dependencies.askama]
 version = "0.9"
 features = ["with-actix-web"]
-