Add clap crate to parse program arguments
[recipes.git] / backend / Cargo.toml
index da94703..4c83bdc 100644 (file)
@@ -2,16 +2,29 @@
 name = "recipes"
 version = "1.0.0"
 authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
-edition = "2018"
+edition = "2021"
 
 [dependencies]
-actix-web = "1.0"
-actix-files = "0.1"
-askama = "0.8" # Template system
-serde = { version = "1.0", features = ["derive"] }
-listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
-ron = "0.5" # Rust object notation, to load configuration files.
-itertools = "0.8"
-sqlite = "0.25"
-
-common = { path = "../common" }
+actix-web = "4"
+actix-files = "0.6"
+serde = {version = "1.0", features = ["derive"]}
+
+time = "0.3"
+
+ron = "0.8" # Rust object notation, to load configuration files.
+itertools = "0.10"
+clap = {version = "4", features = ["derive"]}
+
+env_logger = "0.9"
+
+r2d2_sqlite = "0.21" # Connection pool with rusqlite (SQLite access).
+r2d2 = "0.8"
+
+futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
+
+common = {path = "../common"}
+
+askama = {version = "0.11", features = ["with-actix-web", "mime", "mime_guess"]}
+askama_actix = "0.13"
+
+rusqlite = {version = "0.28", features = ["bundled"]}