Lot of thing
[recipes.git] / backend / Cargo.toml
index 7f7e2e1..06afa24 100644 (file)
@@ -5,18 +5,27 @@ authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
 edition = "2018"
 
 [dependencies]
-actix-web = "2.0"
-actix-rt = "1.0"
+actix-web = "2"
+actix-rt = "1"
 actix-files = "0.2"
-askama = "0.8" # Template system
 serde = { version = "1.0", features = ["derive"] }
 listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
 ron = "0.5" # Rust object notation, to load configuration files.
-itertools = "0.8"
-env_logger = "0.7"
+itertools = "0.9"
+
+r2d2_sqlite = "0.15" # Connection pool with rusqlite (SQLite access).
+r2d2 = "0.8"
+
+futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
 common = { path = "../common" }
 
 [dependencies.rusqlite]
-version = "0.21"
-features = ["bundled"]
\ No newline at end of file
+version = "0.22"
+features = ["bundled"]
+
+# Template system.
+[dependencies.askama]
+version = "0.9"
+features = ["with-actix-web"]
+