Lot of thing
[recipes.git] / backend / Cargo.toml
index 6e21efe..06afa24 100644 (file)
@@ -8,14 +8,24 @@ edition = "2018"
 actix-web = "2"
 actix-rt = "1"
 actix-files = "0.2"
-askama = "0.9" # Template system
 serde = { version = "1.0", features = ["derive"] }
 listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
 ron = "0.5" # Rust object notation, to load configuration files.
 itertools = "0.9"
 
+r2d2_sqlite = "0.15" # Connection pool with rusqlite (SQLite access).
+r2d2 = "0.8"
+
+futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
+
 common = { path = "../common" }
 
 [dependencies.rusqlite]
-version = "0.23"
+version = "0.22"
 features = ["bundled"]
+
+# Template system.
+[dependencies.askama]
+version = "0.9"
+features = ["with-actix-web"]
+