Move all the backend code to a 'backend' directory.
[rup.git] / backend / Cargo.toml
diff --git a/backend/Cargo.toml b/backend/Cargo.toml
new file mode 100644 (file)
index 0000000..9b3574f
--- /dev/null
@@ -0,0 +1,26 @@
+[package]
+name = "rup"
+version = "1.0.0"
+authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
+edition = "2018"
+
+[dependencies]
+actix-web = "2.0"
+actix-rt = "1.1"
+actix-files = "0.2"
+askama = "0.10" # Template system
+serde = { version = "1.0", features = ["derive"] }
+
+openssl = "0.10"
+
+listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
+ron = "0.6" # Rust object notation, to load configuration files.
+itertools = "0.9"
+percent-encoding = "2.1"
+base64 = "0.12"
+rand = "0.7"
+
+[profile.release]
+codegen-units = 1
+lto = true
+panic = 'abort'