Add a common crate.
[rup.git] / backend / Cargo.toml
index 9b3574f..27b8ad6 100644 (file)
@@ -8,7 +8,6 @@ edition = "2018"
 actix-web = "2.0"
 actix-rt = "1.1"
 actix-files = "0.2"
-askama = "0.10" # Template system
 serde = { version = "1.0", features = ["derive"] }
 
 openssl = "0.10"
@@ -20,6 +19,22 @@ percent-encoding = "2.1"
 base64 = "0.12"
 rand = "0.7"
 
+r2d2_sqlite = "0.15" # Connection pool with rusqlite (SQLite access).
+r2d2 = "0.8"
+
+futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
+
+common = { path = "../common" }
+
+[dependencies.rusqlite]
+version = "0.22"
+features = ["bundled"]
+
+# Template system.
+[dependencies.askama]
+version = "0.9"
+features = ["with-actix-web"]
+
 [profile.release]
 codegen-units = 1
 lto = true