Initial model + some various changes
[recipes.git] / backend / Cargo.toml
index 64f90f7..7af3811 100644 (file)
@@ -2,29 +2,26 @@
 name = "recipes"
 version = "1.0.0"
 authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
-edition = "2018"
+edition = "2021"
 
 [dependencies]
-actix-web = "2"
-actix-rt = "1"
-actix-files = "0.2"
-serde = { version = "1.0", features = ["derive"] }
-listenfd = "0.3" # To watch file modifications and automatically launch a build process (only used in dev/debug).
-ron = "0.6" # Rust object notation, to load configuration files.
-itertools = "0.9"
-
-r2d2_sqlite = "0.16" # Connection pool with rusqlite (SQLite access).
+actix-web = "4"
+actix-files = "0.6"
+serde = { version = "1.0", features = [ "derive" ] }
+
+ron = "0.8" # Rust object notation, to load configuration files.
+itertools = "0.10"
+
+env_logger = "0.9"
+
+r2d2_sqlite = "0.21" # Connection pool with rusqlite (SQLite access).
 r2d2 = "0.8"
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
 common = { path = "../common" }
 
-[dependencies.rusqlite]
-version = "0.23"
-features = ["bundled"]
+askama = { version = "0.11", features = ["with-actix-web", "mime", "mime_guess"] }
+askama_actix = "0.13"
 
-# Template system.
-[dependencies.askama]
-version = "0.9"
-features = ["with-actix-web"]
+rusqlite = { version = "0.28", features = ["bundled"] }