Add clap crate to parse program arguments
[recipes.git] / backend / Cargo.toml
index 7af3811..4c83bdc 100644 (file)
@@ -7,10 +7,13 @@ edition = "2021"
 [dependencies]
 actix-web = "4"
 actix-files = "0.6"
-serde = { version = "1.0", features = [ "derive" ] }
+serde = {version = "1.0", features = ["derive"]}
+
+time = "0.3"
 
 ron = "0.8" # Rust object notation, to load configuration files.
 itertools = "0.10"
+clap = {version = "4", features = ["derive"]}
 
 env_logger = "0.9"
 
@@ -19,9 +22,9 @@ r2d2 = "0.8"
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
-common = { path = "../common" }
+common = {path = "../common"}
 
-askama = { version = "0.11", features = ["with-actix-web", "mime", "mime_guess"] }
+askama = {version = "0.11", features = ["with-actix-web", "mime", "mime_guess"]}
 askama_actix = "0.13"
 
-rusqlite = { version = "0.28", features = ["bundled"] }
+rusqlite = {version = "0.28", features = ["bundled"]}