Update dependencies
[valheim_web.git] / backend / Cargo.toml
index 2dbae9f..1c22b3c 100644 (file)
@@ -2,22 +2,23 @@
 name = "valheim_web"
 version = "1.0.0"
 authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
-edition = "2018"
+edition = "2021"
 
 [dependencies]
-actix-web = "2"
-actix-rt = "1"
-actix-files = "0.2"
+actix-web = "4"
+actix-files = "0.6"
+askama_actix = "0.13"
+
 serde = { version = "1.0", features = ["derive"] }
 
-ron = "0.6" # Rust object notation, to load configuration files.
+ron = "0.7" # Rust object notation, to load configuration files.
 itertools = "0.10"
 
 chrono = "0.4"
 
-sysinfo = "0.16"
+sysinfo = "0.23"
 
-cached = "0.23"
+cached = "0.34"
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
@@ -25,8 +26,8 @@ common = { path = "../common" }
 
 # Template system.
 [dependencies.askama]
-version = "0.9"
+version = "0.11"
 features = ["with-actix-web"]
 
 [target.'cfg(unix)'.dependencies]
-systemd = "0.8"
\ No newline at end of file
+systemd = "0.10"