Update dependencies and adapt to new sysinfo API
[minecraft_web.git] / backend / Cargo.toml
index efb9eaf..d1296d3 100644 (file)
@@ -5,9 +5,9 @@ authors = ["GrĂ©gory Burri <greg.burri@gmail.com>"]
 edition = "2018"
 
 [dependencies]
-actix-web = "3"
-actix-files = "0.5"
-askama_actix = "0.11"
+actix-web = "4"
+actix-files = "0.6"
+askama_actix = "0.13"
 
 minecraft-client-rs = "0.1"
 
@@ -15,14 +15,14 @@ serde = { version = "1.0", features = ["derive"] }
 
 fs_extra = "1.2.0"
 
-ron = "0.6" # Rust object notation, to load configuration files.
+ron = "0.7" # Rust object notation, to load configuration files.
 itertools = "0.10"
 
 chrono = "0.4"
 
-sysinfo = "0.18"
+sysinfo = "0.23"
 
-cached = "0.23"
+cached = "0.34"
 
 futures = "0.3" # Needed by askam with the feature 'with-actix-web'.
 
@@ -30,5 +30,5 @@ common = { path = "../common" }
 
 # Template system.
 [dependencies.askama]
-version = "0.10"
+version = "0.11"
 features = ["with-actix-web"]
\ No newline at end of file